Binance Pay issues

Minor incident Binance Pay Transactions Payouts
2024-08-08 18:38 CEST · 1 month, 1 week, 4 days, 9 hours, 35 minutes

Updates

Update

We’re now in the final steps of this process.
We will be submitting the updated application within end of next week, after which Binance Pay should be up and running again.
Thank you for the wait in the meantime.

September 13, 2024 · 18:02 CEST
Update

We’re still working with the Binance team to resolve this.
We expect Binance Pay to come back up within the second week of September. (this was a lie, it’s taking a little longer)

September 2, 2024 · 14:54 CEST
Monitoring

We’re still working with the Binance team to resolve the issue.

August 19, 2024 · 16:44 CEST
Update

We’re still working the Binance team on this.

August 17, 2024 · 21:57 CEST
Monitoring

We’re still working with the Binance team to resolve the issue.

August 16, 2024 · 13:56 CEST
Investigating

We’re still working with the Binance team.

August 12, 2024 · 15:41 CEST
Investigating

The issue is related to ongoing checks by the Binance Pay team, we’re working with them to resolve the situation.

We believe it will not take less than a couple of weeks, unfortunately, after which the funds will be paid out to merchants and payments will be able to be processed again.

August 9, 2024 · 16:35 CEST
Investigating

The Binance team is processing our request, they’re investigating internally the cause of the issue and will get back to us within Monday.

Funds are not lost, payouts will be processed as soon as the block is removed.

August 9, 2024 · 14:39 CEST
Investigating

The Binance team is still investigating the issue, they should provide us with an update within the next 24 hours.

August 8, 2024 · 21:45 CEST
Issue

Binance has stopped processing payments for our platform account.
We’re working with their team to hopefully restore the solution.
We’ll post here more details and info as soon as we have them.

August 8, 2024 · 18:38 CEST

← Back