Invoices not appearing, sales missing

Minor incident API Internal API Developers API
2022-06-02 10:49 CEST · 4 hours, 25 minutes

Updates

Resolved

Every invoice status has been restored.
We will be working in the following days to make sure that every data restored is 100% correct by comparing it with previous backups.

As general information, the issue was caused to a recent release aiming to patch Solana issues due to their own blockchain (status.solana.com) not working at least once a day. The release did not go as expected and invoice statuses were removed, which are not restored.

June 2, 2022 · 15:14 CEST
Update

Invoices have been restored up to August 21st, 2021.
We’re restoring older invoices which may now appear as “VOIDED”.
New invoices and transaction detection are now being processed as expected.

June 2, 2022 · 12:53 CEST
De-escalate

Today’s statuses have been restored within the 30 minutes timeframe.
We’re now working on restoring the status of older invoices (not data, as no data has been lost).

June 2, 2022 · 11:31 CEST
Investigating

No data has been lost, the invoice statuses were wrongly updated.
We’re working on restoring them, it should not take more than 30 minutes.
Sales, Products, Transaction detection and any other site functions are not affected.
Ongoing sales might be affected, but they will be restored as well.

June 2, 2022 · 11:01 CEST
Issue

We’re currently investigating the issue.

June 2, 2022 · 10:49 CEST

← Back