Monero Payouts

Minor incident Monero Node Payouts
2022-07-21 09:25 CEST · 49 minutes

Updates

Resolved

The issue has been solved, payouts should start being sent soon.

July 21, 2022 · 10:14 CEST
Issue

We have detected some issues with Monero Payouts, we’re currently working on it.
We will provide more details once the issue has been solved.

July 21, 2022 · 09:26 CEST

← Back