Email deliverability issue

Major incident Email delivery system
2022-08-15 13:47 CEST · 1 hour, 38 minutes

Updates

Resolved

Email delivery system is now working as expected again.
We will resend invoices processed and created between 13:00 and 15:30 CET within the next hours.

August 15, 2022 · 15:26 CEST
Issue

We’re experiencing issues delivering emails for our merchants.
The issue is related with AWS SES, we’re currently working on fixing it ASAP.

August 15, 2022 · 13:48 CEST

← Back